Autor Thema: GR02 Connection Refuse  (Gelesen 1453 mal)

SteRa

  • Newbie
  • *
  • Beiträge: 6
  • Gerät: Samsung S7
  • Version: Android 7
GR02 Connection Refuse
« am: 19.11.2017, 11:28:55 »
Hallo,

ich habe beim automatischen Wechsel der Zonen immer ein Fehler (GR02) Connection Refuse.

Beim testen der Serviceeinstellungen funktioniert alles und der TestReading kommt auch in Fhem an. Wenn ich Wlan ausschalte und im LTE Netz eine GeoZone nochmals speicher, wird auch alles richtig übertragen und Fhem bekommt den Reading "arrived Zuhause"!?
Das Problem kommt nur im normalen Ablauf vor, nur warum?

Ich habe schon in Fhem sämtliche Sicherheiten reduziert und dachte evtl. es liegt daran, aber es geht leider nicht..

ich hoffe Ihr habt eine Idee.

Gruß,
SteRa

PS: Android 7 und Samsung Galaxy S7

Admin

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 759
    • EgiGeoZone
  • Gerät: Xiaomi Redmi Note 5, Samsung Galaxy Note 2, S4, S5, S2, S7
  • Version: MIUI 10.0 Global, Android 4.4, 5, 6, 7, 8, 8.1, 12, 13
Re: GR02 Connection Refuse
« Antwort #1 am: 19.11.2017, 13:21:01 »
Hi!

Schicke mir mal deine Log-Datei per E-Mail. Vielleicht kann  ich was erkennen.
Ansonsten wenn du diesen Fehler bekommst, dann sollten alle Einstellungen ertmal richtig sein.
Schöne Grüße
Egmont

SteRa

  • Newbie
  • *
  • Beiträge: 6
  • Gerät: Samsung S7
  • Version: Android 7
Re: GR02 Connection Refuse
« Antwort #2 am: 21.11.2017, 19:46:17 »
Hey,

ich habe mal selbst in den Log etwas nachgeguckt und den erzeugten Link im Browser ausgeführt.
Hier kam der gleiche Fehler, wie im Log, dass das Datumsformat nicht stimmt.

Das Datum scheint allgemein leer zu sein?


[DEBUG::de.egi.geofence.geozone.Worker::de.egi.geofence.geozone.Worker] - server url chosen: http://xxxxxxx.myfritz.net/webhook/geo?id=xxxxx&name=Zuhause&entry=0&date=&latitude=xx.xxx&longitude=x.xxxxxxx&device=xxxxx
..
..
..
2017-11-20 15:17:07,521 - [INFO::de.egi.geofence.geozone.utils.Api::de.egi.geofence.geozone.utils.Api] - timeout: 30000
2017-11-20 15:17:07,876 - [INFO::de.egi.geofence.geozone.utils.Api::de.egi.geofence.geozone.utils.Api] - result after get: NOK Specified date '' does not match ISO8601 UTC format (1970-01-01T00:00:00Z)




Admin

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 759
    • EgiGeoZone
  • Gerät: Xiaomi Redmi Note 5, Samsung Galaxy Note 2, S4, S5, S2, S7
  • Version: MIUI 10.0 Global, Android 4.4, 5, 6, 7, 8, 8.1, 12, 13
Re: GR02 Connection Refuse
« Antwort #3 am: 22.11.2017, 08:29:46 »
Zitat
Das Datum scheint allgemein leer zu sein?
Kann nicht sein. Da würden ja alle Benutzer mir aufs Dach steigen  ;)
Das ist ein Fehler in deinem Test, das Datum wird schon am Ende mitgegeben.
Verwendest du da die Fhem-URL im Server-Profil?


Zitat
ch habe beim automatischen Wechsel der Zonen immer ein Fehler (GR02) Connection Refuse
Ist ein ganz anderer Fehler. Deshalb wollte ich den Abschnitt aus der Log mit dem GR02-Fehler sehen.
Der kam ja bei deinem Test nicht, sonst würdest du nicht die Meldung result after get: NOK Specified date '' does not match ISO8601 UTC format (1970-01-01T00:00:00Z)  vom Server bekommen.

Schöne Grüße
Egmont

SteRa

  • Newbie
  • *
  • Beiträge: 6
  • Gerät: Samsung S7
  • Version: Android 7
Re: GR02 Connection Refuse
« Antwort #4 am: 22.11.2017, 21:05:03 »
Was meinst du damit?
Verwendest du da die Fhem-URL im Server-Profil?

Ist doch richtig ein ServerProfil anzulegen mit der Adresse oder nicht?

Ich habe alle Adressen ausprobiert, mit dem Hautbenutzer, mit dem Webhook Benutzer usw...Testverbindungen usw. kommen ja immer durch.
1-2 mal kam auch der Status "arrived" durch, aber ansonsten immer der Fehler...

http://xxxxxxx.myfritz.net/fhem/geo   -> hier wird der Port umgeleitet von 80 auf 8085
http://xxxxxxx.myfritz.net:8086/webhook/geo


Admin

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 759
    • EgiGeoZone
  • Gerät: Xiaomi Redmi Note 5, Samsung Galaxy Note 2, S4, S5, S2, S7
  • Version: MIUI 10.0 Global, Android 4.4, 5, 6, 7, 8, 8.1, 12, 13
Re: GR02 Connection Refuse
« Antwort #5 am: 23.11.2017, 06:35:45 »
Zitat
Was meinst du damit?
Verwendest du da die Fhem-URL im Server-Profil?
Im Server Profil kann man ganz oben die Fhem-URL angeben, dann als nächstes noch twei URLs für Betreten und Verlassen. Du brauchst die oberste.

Ohne der ganzen GR02-Fehlermeldung aus der Log-Datei kann ich dir nicht weiter helfen.
Schöne Grüße
Egmont

SteRa

  • Newbie
  • *
  • Beiträge: 6
  • Gerät: Samsung S7
  • Version: Android 7
Re: GR02 Connection Refuse
« Antwort #6 am: 23.11.2017, 07:29:36 »
Guten Morgen,

ich habe gestern Abend nochmal alles gelöscht, auch in Fhem das Geofancy Modul.

Nach dem ich alles neu eingerichtet habe, funktioniert das komischerweise  :o

Allerdings mit dieser Adresse und bin mir nicht sicher, ob ich das vorher ausprobiert habe...

http://xxxxxxx.myfritz.net:8086/fhem/geo

Mit dem webhook Benutzerdaten und deren Port... Warum das jetzt mit dem Webname Geo nicht funktioniert, ist mir noch nicht klar..

Gruß,
SteRa



SteRa

  • Newbie
  • *
  • Beiträge: 6
  • Gerät: Samsung S7
  • Version: Android 7
Re: GR02 Connection Refuse
« Antwort #7 am: 27.11.2017, 13:38:39 »
Hallo,

ich hatte den Fehler immer noch, bin mir jetzt aber hoffentlich sicher voran es lag.. Die App fragt ja vorher ab, welche Berechtigungen gegebenen und ob die Akkuoptimierung ausgestellt werden soll.

Ich habe allerdings die Option "Datensparen" eingeschaltet und dann durften natürlich keine Hintergrunddaten im mobilen Netz gesendet werden. Seitdem die Ausnahme für die App hinterlegt ist, funktioniert es auch bis jetzt  ;)

Gruß,
SteRa