Autor Thema: FHEM (Geofancy) hinter HAProxy  (Gelesen 679 mal)

PaulGuijt

  • Newbie
  • *
  • Beiträge: 22
  • Galaxy Note 3 & FHEM
  • Gerät: Samsung Galaxy Note 3
  • Version: 5.0
FHEM (Geofancy) hinter HAProxy
« am: 22.12.2016, 18:14:04 »
Hallo Alle,

Ich versuche (für Geofancy) FHEM hinter ein ReverseProxy zu verstecken.

Dafür habe ich HAProxy installiert auf meinem Pi, im config
listen abc
        mode http
        bind :x
        acl isabc path_end -i /bli/bla
        http-request deny unless isabc
        server server1 localhost:y
hineingefügt und HAProxy gestartet.

Nun versuche ich Egigeozone ein Bericht ein zu schicken über https://meinserver:x/bli/bla, aber das wirkt nicht. Es wirkt aber mit https://meinserver:y/bli/bla.

Was mache ich falsch? Hat jemand vielleicht irgendeine Vorschläge?

Freundliche Grüße,
Paul

PaulGuijt

  • Newbie
  • *
  • Beiträge: 22
  • Galaxy Note 3 & FHEM
  • Gerät: Samsung Galaxy Note 3
  • Version: 5.0
Re: FHEM (Geofancy) hinter HAProxy
« Antwort #1 am: 22.12.2016, 22:07:58 »
Später habe ich Anweisungen gefunden dass die benötigde SSL PassThrough das Problem wäre.
Jetzt hat es geklappt, mit hilfe von https://serversforhackers.com/using-ssl-certificates-with-haproxy.

Was wirkt:listen abc
        bind :x
        mode tcp
        option tcplog
        acl isabc path_end -i /bli/bla
        http-request deny unless isabc
        server server1 localhost:y

Freundliche Grüße,
Paul

PaulGuijt

  • Newbie
  • *
  • Beiträge: 22
  • Galaxy Note 3 & FHEM
  • Gerät: Samsung Galaxy Note 3
  • Version: 5.0
Re: FHEM (Geofancy) hinter HAProxy
« Antwort #2 am: 20.01.2017, 21:41:11 »
Und letztens habe ich Geofancy, HAProxy usw. verabschiedet. Ich nütze jetzt der Telegram plugin von egiGeozone, siehe meine andere Beiträge.

Grüße,
Paul