Autor Thema: EgiGeoZone und Geofency  (Gelesen 3738 mal)

bobby1000

  • Newbie
  • *
  • Beiträge: 4
  • Gerät: Samsung Galaxy S4
  • Version: Android 4.4.2
EgiGeoZone und Geofency
« am: 20.12.2014, 20:55:10 »
Als erstes einmal vielen Dank für die tolle App. Wobei ich sie bisher nur für das Schalten von Bluetooth und WLAN an den Heimkoordinaten verwende.
Ich würde es auch gerne für die Anwesenheitserkennung unter FHEM einsetzen.
Nun habe ich das Problem, das ich FHEM bisher nur zum Spielen einsetze, Also quasi blutiger Anfänger bin.
Ich habe mir im FHEM Forum den kompletten Tread zu dieser App bereits reingezogen, aber ich bekomme einfach keine Verbindung zwischen EgiGeoZone und FHEM hin, da ich einfach nicht verstehe wir Geofancy in der fehm.cfg Konfiguriert werden muss.
Ich bin mir bewusst darüber das das ebenso ein Fall für das FHEM Forum ist, habe mich aber bewusst für das hiesige Forum entschieden, damit ich nachher keine Appspeziefischen Probleme lösen muss.

Vielen Dank für eure Hilfe

Admin

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 759
    • EgiGeoZone
  • Gerät: Xiaomi Redmi Note 5, Samsung Galaxy Note 2, S4, S5, S2, S7
  • Version: MIUI 10.0 Global, Android 4.4, 5, 6, 7, 8, 8.1, 12, 13
Re: EgiGeoZone und Geofency
« Antwort #1 am: 20.12.2014, 21:56:43 »
Willkommen im Forum!
Freut mich, positives über die App zu hören :-)

Ich habe das Geofancy bei mir folgendermaßen konfiguriert:


define geofancy GEOFANCY geo
attr geofancy devAlias b2ccscsf-1070-3927-8824-58220bcabca05f:Egi
attr geofancy room Haus

define egi.zuHause notify geofancy:currLoc_Egi:.zuHause {fhem("set Abwesend nein")}
define egi.nichtHause notify geofancy:currLoc_Egi:.underway {fhem("set Abwesend ja")}

define Abwesend dummy
attr Abwesend group Abwesenheitssteuerung
attr Abwesend room Haus
attr Abwesend webCmd ja:nein


Um DeviceId (UUID) zu bekommen, würde ich in der App bei den Servereinstellungen in die Geofancy-URL deine URL, den Benutzer, das Passwort und sonstige Sachen, die du konfiguriert hast eingeben. Vorher muss das Geofancy Modul laut Beschreibung eingerichtet werden: http://fhem.de/commandref.html#GEOFANCY
Dann auf Testen drücken und im Fhem unter "geofancy" gucken, was ankommt. Diesen Wert dann nehmen und als DeviceId hinter devAlias eintragen. Beim Testen ist die Zone immer name:EgiGeoZone. Im Echbetrieb ist es der Name der Zone.
Siehe auch http://egigeozone.de/manual/default.html#Servereinstellungen

attr geofancy devAlias b2ccscsf-1070-3927-8824-58220bcabca05f:Egi

Hoffe geholfen zu haben. Ansonsten bitte konkreter fragen.
Schöne Grüße
Egmont

bobby1000

  • Newbie
  • *
  • Beiträge: 4
  • Gerät: Samsung Galaxy S4
  • Version: Android 4.4.2
Re: EgiGeoZone und Geofency
« Antwort #2 am: 20.12.2014, 22:19:51 »
Erst einmal vielen Dank für die schnelle Antwort.
Aber in der Antwort ist mein eigentliches Problem wieder aufgetaucht.
Zitat
Vorher muss das Geofancy Modul laut Beschreibung eingerichtet werden: http://fhem.de/commandref.html#GEOFANCY
Ich habe leider keinen blassen Schimmer wie ich Geofancy einrichten muss.
Auch die commandref zu Geofancy habe ich mir bereits ausgiebig angeschaut. Aber ich verstehe nicht wirklich wie bzw. was ich dort einstellen muss.
Viele Parameter gibt es ja nicht.

define ist klar. Aber wie komme ich an die Adresse ? mir reicht der lokale Zugriff. also müsste die Adresse http://192.168.1.1/fehm/geo lauten.
Den Port verstehe ich auch nicht. Ist der wie bei dem Webzugriff? 8083.

Und den devAlias verstehe ich auch nicht so wirklich. attr geofancy devAlias b2ccscsf-1070-3927-8824-58220bcabca05f:EgiWird in der Eingabe ja wahrscheinlich nicht nur so wie es in deiner fhem.cfg steht eingegeben.
Wie kann benutzer und OPasswort damit erstellt werden.

Sorry, wenn ich hier nach Basics frage, Aber ich sammele gerade noch fleißig Input und versuche damit wenigstens die Basics zu Verstehen.

Vielen Dank

Admin

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 759
    • EgiGeoZone
  • Gerät: Xiaomi Redmi Note 5, Samsung Galaxy Note 2, S4, S5, S2, S7
  • Version: MIUI 10.0 Global, Android 4.4, 5, 6, 7, 8, 8.1, 12, 13
Re: EgiGeoZone und Geofency
« Antwort #3 am: 20.12.2014, 22:38:32 »
Zitat
Ich habe leider keinen blassen Schimmer wie ich Geofancy einrichten muss.
so wie ich unten beschrieben hatte. Erstmal mit einem falschen devAlias, den du dann später berichtigen wirst. Siehe weiter unten.
define geofancy GEOFANCY geo
attr geofancy devAlias b2ccscsf-1070-3927-8824-58220bcabca05f:Egi
attr geofancy room Haus

Zitat
. also müsste die Adresse http://192.168.1.1/fehm/geo lauten.
Den Port verstehe ich auch nicht. Ist der wie bei dem Webzugriff? 8083.
Wenn richtig, dann sollte es stimmen.

Zitat
b2ccscsf-1070-3927-8824-58220bcabca05f
Bekommst du, wie beschrieben mit dem Testen der Servereinstellungen in der App.
1. Servereinstellungen einrichten
2. Test-Button
3. In Fhem im geofancy die ID (devAlias) auslesen und in der Konfig eintragen

Zitat
Wie kann benutzer und OPasswort damit erstellt werden.
Brauchst du nur, wenn du fhem absichern möchtest. Für den test geht es auch ohne. Später aber in Fhem lesen, wie man einen Benutzer und Passwort anlegt.


Schöne Grüße
Egmont

bobby1000

  • Newbie
  • *
  • Beiträge: 4
  • Gerät: Samsung Galaxy S4
  • Version: Android 4.4.2
Re: EgiGeoZone und Geofency
« Antwort #4 am: 21.12.2014, 14:49:49 »
Sorry, wenn ich schon wieder nerfe.
Aber einige Sachen habe ich nun endlich verstanden. Aber nun streikt die App.
Eigentlich habe ich nur die Adresse eingegeben und den Benutzer (für FHEM) und das Passwort
Aber wenn ich nun in den Servereinstellungen auf Test klicke kommt gar nichts.

Es gibt kein rotes Fähnchen, also habe ich scheinbar alles richtig gemacht.
Aber leider gibt es auch kein weisses Fähnchen.

Vielen Dank schon mal vorab für die Geduld

Admin

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 759
    • EgiGeoZone
  • Gerät: Xiaomi Redmi Note 5, Samsung Galaxy Note 2, S4, S5, S2, S7
  • Version: MIUI 10.0 Global, Android 4.4, 5, 6, 7, 8, 8.1, 12, 13
Re: EgiGeoZone und Geofency
« Antwort #5 am: 21.12.2014, 17:25:04 »
Sorry, wenn ich schon wieder nerfe.
Aber einige Sachen habe ich nun endlich verstanden. Aber nun streikt die App.
Eigentlich habe ich nur die Adresse eingegeben und den Benutzer (für FHEM) und das Passwort
Aber wenn ich nun in den Servereinstellungen auf Test klicke kommt gar nichts.

Es gibt kein rotes Fähnchen, also habe ich scheinbar alles richtig gemacht.
Aber leider gibt es auch kein weisses Fähnchen.

Vielen Dank schon mal vorab für die Geduld

Dann hast du alles richtig gemacht! Beim Test kommt keine Benachrichtigung (Fähnchen)! Du musst nun in Fhem unter Geofancy gucken, oder eventuell in den Logs von Fhem.

Siehe auch https://www.egigeozone.de/forum/index.php?topic=31.msg105#msg105
« Letzte Änderung: 21.02.2023, 10:43:31 von Admin »
Schöne Grüße
Egmont

Admin

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 759
    • EgiGeoZone
  • Gerät: Xiaomi Redmi Note 5, Samsung Galaxy Note 2, S4, S5, S2, S7
  • Version: MIUI 10.0 Global, Android 4.4, 5, 6, 7, 8, 8.1, 12, 13
Re: EgiGeoZone und Geofency
« Antwort #6 am: 23.12.2014, 08:40:11 »
Anbei bin ich auf einen ganz interessanten Artikel gestoßen: http://paradies.aufdemdach.net/index.php/hausautomation/98-10-anwesenheit
Schöne Grüße
Egmont

bobby1000

  • Newbie
  • *
  • Beiträge: 4
  • Gerät: Samsung Galaxy S4
  • Version: Android 4.4.2
Re: EgiGeoZone und Geofency
« Antwort #7 am: 23.12.2014, 09:58:58 »
Vielen Dank für deine Hilfe,
werde mir üben bzw. nach den Feiertagen das ganze noch mal ausführlich anschauen und damit rum experimentieren.
Bisher hat mir dieser Tread auf jeden Fall deutlich weiter geholfen.

Vielen Dank dafür und ein frohes Weihnachtsfest